[PLUG] Problem in Slackware 12 ?

Pranav Peshwe pranavpeshwe at gmail.com
Fri Nov 16 23:29:28 IST 2007

Hi Abhijit,

On Nov 16, 2007 12:39 PM, Abhijeet Anant Sane <abhijit.sane at symphonysv.com>

> hi ,
> I am facing a strange problem . with the harddisk detection when using
> Fedora
> Core and slackware 12.
> When i install Fedora core 7 on my HP dc7600 machine . The harddisks are
> detected as "hda". If I install slackware 12 on the same machine the
> harddisks are detected as "sda".
> I am not sure why this is happening. This is causing me a lot of grief
> because
> when ever i download the latest kernel on the slackware setup and compile
> it
> correctly. the newer kernel detects the hardisk as "hda" and not "sda" .

> The /etc/fstab file for mounting the partitions will be wrong in  case of
> newer kernel and booting does not work for my newer kernels. My newer
> kernels
> all boot fine on fedore core 7 based machines.

One solution would be to not use /dev/(hda/sda) in fstab at all.
Use LABEL (which can be set by tune2s) or uuid from

> I am using the .config file found on the slackware 12 install CD.
> I then run "make oldconfig" on the same config and then proceed with
> compilations.
> Let me know if i am forgetting to set some options in "make menuconfig"
> waiting for u r response.

Not sure about this, but will enabling libata make a difference ? A diff of
both the .config files might give some hint.


Best regards,

If it's not tested, it's broken. - Bruce Eckel

More information about the Plug-mail mailing list