[PLUG] Inserting module in 2.4.20-8

Milind Arun Choudhary milindchoudhary at gmail.com
Mon Dec 1 01:53:25 PST 2008


On 12/1/08, sandeep mane <sandeepmanekolhapur at gmail.com> wrote:


>> --- Jayesh Agrawal <jayeshleo at gmail.com> wrote:
>> | [root at localhost root]# insmod ./hello-1.o
>> | ./hello-1.o: kernel-module version mismatch
>> | ./hello-1.o was compiled for kernel version
>> | 2.4.20
>> | while this kernel is version 2.4.20-8smp.
>> \--
>>
>> This clearly tells you the error. Your kernel headers
>> are for 2.4.20, but, your current running kernel is a
>> smp kernel.
>>
>> Always load driver modules to the corresponding
>> kernels to which they are built for.
>>
true

Any specific reason for using 2.4?

Consider reading this.. if you already haven't .
http://www.kroah.com/lkn/
http://tldp.org/LDP/lkmpg/

-- 
Milind Arun Choudhary



More information about the plug-mail mailing list