[PLUG] (no subject)

Chetan Kumar chetanku at gmail.com
Sun Jan 18 16:01:17 PST 2009


On Mon, Jan 19, 2009 at 12:26 AM, Ratnadeep Deshmane
<ratnadeepdeshmane at gmail.com> wrote:
> Hello friends,
> I have nokia 3230 with idea gprs and i want to configure it for open
> suse 11.0.  I have problem with wvdial command...

SNIP

> i have edited wvdial.conf properly.. it just don't detect the modem ..
>
> please help me configure it properly..
> i am stuck at this problem for many days..

The kernel has to have "USB Modem (CDC ACM) support"
What is the output for "lsmod|grep acm" ?
For me it is
---------------
cdc_acm                12672  0
usbcore               113344  5 cdc_acm,usbhid,ehci_hcd,uhci_hcd
--------------
USB modems are used with /dev/ttyACM* devices
So, once the correct modules are loaded (manually or otherwise) and
the modem is "on" (for my palm treo 680, there is a "USB modem"
application I run on the handset before I do the wvdialconf step)

"wvdialconf wvdial.conf" should show something like this
-------------
Scanning your serial ports for a modem.

Port Scan<*1>: Scanning ttyS1 first, /dev/modem is a link to it.
ttyS1<*1>: ATQ0 V1 E1 -- failed with 2400 baud, next try: 9600 baud
ttyS1<*1>: ATQ0 V1 E1 -- failed with 9600 baud, next try: 115200 baud
ttyS1<*1>: ATQ0 V1 E1 -- and failed too at 115200, giving up.
Port Scan<*1>: S0   S2   S3
ttyACM0<*1>: ATQ0 V1 E1 -- OK
ttyACM0<*1>: ATQ0 V1 E1 Z -- OK
ttyACM0<*1>: ATQ0 V1 E1 S0=0 -- OK
ttyACM0<*1>: ATQ0 V1 E1 S0=0 &C1 -- OK
ttyACM0<*1>: ATQ0 V1 E1 S0=0 &C1 &D2 -- OK
ttyACM0<*1>: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0 -- OK
ttyACM0<*1>: Modem Identifier: ATI -- LowRider
ttyACM0<*1>: Speed 4800: AT -- OK
ttyACM0<*1>: Speed 9600: AT -- OK
ttyACM0<*1>: Speed 19200: AT -- OK
ttyACM0<*1>: Speed 38400: AT -- OK
ttyACM0<*1>: Speed 57600: AT -- OK
ttyACM0<*1>: Speed 115200: AT -- OK
ttyACM0<*1>: Speed 230400: AT -- OK
ttyACM0<*1>: Speed 460800: AT -- OK
ttyACM0<*1>: Max speed is 460800; that should be safe.
ttyACM0<*1>: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0 -- OK

Found an USB modem on /dev/ttyACM0.
Modem configuration written to wvdial.conf
ttyACM0<Info>: Speed 460800; init "ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0"
-------------

The wfdial.conf reads

-------------
[Dialer Defaults]
Modem = /dev/ttyACM0
Baud = 460800
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
ISDN = 0
Modem Type = USB Modem
; Phone = <Target Phone Number>
; Username = <Your Login Name>
; Password = <Your Password>
-------------
At this stage, one is ready to go.
I hope there are sufficient hints here to get you started.
Cheers
Chetan



More information about the plug-mail mailing list