[PLUG] X doesnt work in 11.04 ubuntu.

Arun Tomar tomar.arun at gmail.com
Fri Apr 29 20:52:55 PDT 2011


On 04/29/11 08:07, Ameet Gholap wrote:
> Hi All,
>
> 10.10 to 11.04 upgrade messed up my system. X doesnt start.
> Only the net connection works. I have found a workaround!
>
> Provide default key-ring during starting. GUI not seen. Only mouse
> pointer and blank screen.
> Now press power. Ubuntu asks for shutdown, restart etc Help and Cancel
> buttons available.
> Click Help to launch help and cancel to abort shutdown.
> Now from that help window, use menus to ask for "Online Help".
> FF launches.
>
> Using that firefox, I am now mailing asking for help.
>
> How can I repair my system?
>
> Thanks.
>
> ~A.
> (\./)
> (o.o)
> ( X )
> This is Bunny. Copy Bunny into your signature to help achieve world domination.
>
> _______________________________________
> Pune GNU/Linux Users Group Mailing List
Ameet,

I'm assuming that you upgraded your system from the package manager with 
dist-upgrade. Well the best way to test whether your graphics card will 
work with 11.04 would be to have a live cd/dvd and run it. if it runs 
well, then you'll know for sure, that 11.04 should run on your system 
without any problem.

now, if your X is giving you errors, first thing is to check the logs. 
you can goto terminal press "CTRL+ALT+F1" or F2 - F6 to goto any of the 
tty's. login and then check the log files for X, /var/log/X.log. It'll 
surely give you the cause of the problem. paste the entire X.log file to 
some pastebin and put the link here to us to review it. you can install 
pastebinit or wgetpastebin. by these utils, you can paste the entire 
file to pastebin via command line. One you get the cause or exact error, 
then we could suggest further solution.

Arun.



More information about the plug-mail mailing list