[PLUG] android bluetooth version support question

Mayuresh mayuresh at acm.org
Mon Nov 26 23:28:53 IST 2012

I have an old (well, not more than a couple of years) bluetooth headset,
which I find not working with a recent android phone.

The BT device spec says:
This device is compliant with Bluetooth Specification 2.1 + EDR supporting
the following profiles: Headset Profile 1.1 and Hands-Free Profile 1.5.

The phone runs android 4.x and its BT spec says:
v3, Supported Profiles (PBAP, PBA, A2DP, GAP, HFP, HSP, OPP, SPP, HID,

So, seems these are not compatible (and some web searches vaguely suggest
3.0 is not backward compatible with 2.1).

<rant>Systematic nexus between hardware and software makers to render old
hardware obsolete so fast?</rant>

Now, shall I give up on this totally? Is the BT version embedded in
hardware or the OS can possibly support a different BT version with some
hacks. (I don't mind giving up 3.0 completely as this is the only BT
device I have.)


More information about the Plug-mail mailing list