[PLUG] problem setting fedora13 iso as repository

Vinayak Kulkarni kulkarnivd2007 at yahoo.co.in
Mon Sep 20 00:10:57 IST 2010

Thanks for the reply.
I performed the step as you have described.

createrepo has generated necessary xml files.

I also created iso.repo file in /etc/yum.repos.d

content of iso.repo

still yum is not installing packages from this source.

it is returning with some error saying "bad id with iso.repo".

Vinayak D. Kulkarni

--- On Sun, 19/9/10, Sankarshan Mukhopadhyay <sankarshan.mukhopadhyay at gmail.com> wrote:

From: Sankarshan Mukhopadhyay <sankarshan.mukhopadhyay at gmail.com>
Subject: Re: [PLUG] problem setting fedora13 iso as repository
To: "Pune GNU/Linux Users Group Mailing List" <plug-mail at plug.org.in>
Date: Sunday, 19 September, 2010, 11:00 AM

On Sun, Sep 19, 2010 at 10:53 AM, Vinayak Kulkarni
<kulkarnivd2007 at yahoo.co.in> wrote:

> Recently I have tried setting Fedora-13-i386-DVD.iso file as repository.
> But, when I tried createrepo it is returning following error,
> createrepo: Directory /media/Fedora13 must be writeable.
> I have mounted image at /media/Fedora13.
> What should be the problem.

Did you mount the DVD ISO, copy the RPMs over to a location with write
permissions and then run createrepo ?

sankarshan mukhopadhyay

Pune GNU/Linux Users Group Mailing List 

More information about the Plug-mail mailing list